Set up Revit Shared Coordinates

5 minutes
11 months ago

When working on a project with multiple interlinked files from different platforms, you need to establish shared coordinates to position the models so that they align with each other when opened in Navisworks and/or Newforma Konekt’s viewer.

This article lists the steps that allow you to establish shared coordinates between your models.

To learn more about key concepts related to positioning, see About Positioning.

Related: Setting up Revit Shared Coordinates

Establish context for the site model

When setting up a project in Revit, it is important to specify the geographic location of the site model, define the survey point and rotate True North to establish a common coordinate position. To learn how to perform those tasks, see Revit’s topic Workflow: Positioning.

By default, the project base point and the survey point are both located at the internal origin. It is recommended that you stay close to it to avoid any bad surprises. To learn more, see Revit’s topic About the Maximum Distance Limit.

Share coordinates between models

Once the site model is georeferenced, you can either publish the coordinates to linked models or acquire the coordinates from a linked model.

Publish coordinates to a linked model

As the owner of the model with the properly set coordinates, you can push those coordinates to any linked model to establish its relative location. To do so, follow the instructions below or watch our short video.

  1. Open the model with the proper coordinates you want to publish from.
  2. Display site points.
    1. Open the desired view.
      Make sure there is no view templates used that could grey out the option for turning the site points on.
    2. Click the View tab > Graphics panel > Visibility/Graphics.
    3. On the Model Categories tab of the Visibility/Graphics dialog, scroll down to Site, and expand it.
    4. Select the following three elements:
      • Project Base Point
      • Survey Point
      • Internal Origin
    5. Click OK.
  3. Select the survey point to make sure that the proper shared site is Current in the model.
  4. Link a model file.
    1. Click the Insert tab > Link panel > Link Revit.
    2. Navigate to the folder that contains the file to link.
    3. Click Open.
  5. Manually relocate the linked model in the proper position for the x, y, and z axes by aligning the grids and levels.
  6. Publish this new location back to the linked model.
    1. In the model’s properties on the left, click <Not Shared>.
    2. In the dialog that appears, click Record current position as “” > Change… to create a new shared site.
    3. In the Location Weather and Site dialog, in the Site tab, select the default shared site and click Duplicate….
    4. Enter a name for the site (e.g. SITE_01).
    5. Click OK. The linked model will change from the default internal coordinates to the new shared site that was just created.
      When saving the current project, a message pops up to first save the new position of the linked model. This will publish the new coordinates back to the linked file, making a change to the shared site of that linked file.
  7. Send the current position of the site model back to the linked model.
    1. Click the diskette icon in the toolbar. This will prompt you to save the linked model.
    2. Click Save to save the new position back to the link.

Acquire coordinates from a linked model

As a collaborator, you can link a file and acquire its internal coordinates. To do so, follow the instructions below or watch our short video.

  1. Open the model for which you want to bring the proper coordinates into.
  2. Turn on the visibility of the site points.
    1. Open the desired view.
      Make sure there is no view templates used that could grey out the option for turning the site points on.
    2. In the ribbon, click the View tab > Graphics panel > Visibility/Graphics.
    3. On the Model Categories tab of the Visibility/Graphics dialog, scroll down to Site, and expand it.
    4. Select the following three elements:
      1. Project Base Point
      2. Survey Point
      3. Internal Origin
    5. Click OK.
  3. Create a new shared site and rename it.
    1. Select the survey point.
    2. In the Location Weather and Site dialog, in the Site tab, select the default shared site and click Duplicate….
    3. Enter a name for the site (e.g. SITE_01).
    4. Click OK.
    5. Back in the Location Weather and Site dialog, make sure the newly created site is selected and click Make Current.
    6. Click OK.
  4. Link in the model with the proper shared site reference.
    1. In the ribbon, click the Insert tab > Link panel > Link Revit.
    2. Navigate to the folder that contains the file to link and set the Positioning option to Auto – By Shared Coordinates to insert it at the correct location in the current model – this will be the reference for the final resting position of the current model.
    3. Click Open.
  5. Relocate your model.
    1. In the ribbon, click Manage tab > Project Location panel > Position > Relocate Project option. This will move the model relative to the shared coordinate system (not the project base point).
    2. Set the model in the proper position for the x, y, and z axes by aligning the grids and levels.
  6. Remove the linked site file.
    1. In the ribbon, click the Manage tab > Manage Project panel > Manage Links.
    2. In the Manage Links dialog, in the Revit tab, select the linked file and click Remove.
    3. Click OK.
  7. Save your model by clicking the diskette icon in the toolbar. This will update the shared site position you have just adjusted.